上一层 后一页

下拉菜单

文件(F)

  • 新建(N):新建一个窗口,输入文字;

  • 打开(O):打开一个文本文件或 .rtf 文件;

  • 退出(X):退出主程序;

  • 退出项上方如有文件名,为最近保存的计算结果文件,最多可显示五项。

视图(V)

  • 选项(O):
      点击“选项”将打开一个对话框,对话框中包含“原始数据”“特殊符号”“显示结果”“系统”等四个选项卡。
      当有子程序处于打开状态,如果对“特殊符号”“显示结果”“系统”等选项卡中的选项进行调整,需要将打开的子程序关闭后重新启动,所做的改动设置方可生效。

    • 原始数据

  • □保存计算结果同时保存原始数据

    • 当勾选“□保存计算结果同时保存原始数据”时,在保存显示结果窗口的计算结果文件同时,自动保存原始输入数据,其文件名、目录同计算结果文件,扩展名为“.mgs”。

  • 自动保留原始数据的历史记录个数

    • 指定最近保存的原始数据文件名数量,文件名历史记录在“数据”下拉菜单中显示,有效范围:1~20。

  • □自动保存原始数据

    • 选择是否按指定间隔分钟数来自动保存子程序当前的输入数据。

    • 自动保存文件的目录为系统的临时文件夹、后缀名为“*.mor”。

    • 系统临时文件夹通常由“TEMP”和“TMP”环境变量指明。系统环境变量可在“控制面板”的“系统”选项卡中单击“环境变量”进行设置,一般用户不需要更改。

  • 自动保存的间隔分钟数

    • 指定自动保存原始数据的间隔分钟数,有效范围:1~600(分钟)。

  • □覆盖同名文件时创建备份

    • 选择是否在保存原始数据文件、需要覆盖同名文件时创建备份。

    • 创建备份,是将被覆盖原文件的后缀名由“*.mgs”改为“*.mg$”。

  • □子程序退出时提示记录工作现场

    • 默认情况下(未勾选),子程序在退出前自动记录工作现场,以后重新打开该子程序时将加载当前退出时的数据。

    • 当勾选“□子程序退出时提示记录工作现场”时,程序将 提示是否保存当前的工作现场。

      • 点击“”,在退出前记录工作现场,以后重新打开子程序时将加载当前退出时的数据。

      • 点击“”,不记录工作现场,以后重新打开子程序时将加载上一次记录的数据。

      • 点击“取消”,不记录工作现场,并将当前输入的数据另存为用户指定的文件名。

  • 特殊符号

  • 定义上/下标(二次方、三次方)、钢筋直径等特殊符号在程序界面及计算结果中显示的字符。

  • 用户可通过键盘或右键弹出菜单(复制、粘贴)等方式,在输入框中输入单个字符来自定义特殊字符。

  • Ⅰ级钢、Ⅱ级钢、Ⅲ级钢、Ⅳ级钢对应的钢筋牌号分别为 HPB300、HRB335、HRB400、HRB500。

  • 显示结果

  • 设置字体

    • 设置计算结果的字体、字形、大小、颜色等。

  • 设置背景颜色

    • 设置计算结果窗体的背景颜色。

  • 计算结果编号所采用的圆点符号

    • 设置计算结果中的条目编号所采用的圆点符号。例如:选择“.”,编号为“1.1”“1.1.1”等;选择“”,编号为“1.1”“1.1.1”等。

    • “预览”窗口将实时显示用户自定义的圆点符号。

  • 计算书中每行允许的最大字符数

    • 设置计算结果输出计算书中每行允许的最大字符数,有效范围为:80~160。

    • 一个英文字母、阿拉伯数字(半角)为一个字符,一个汉字为两个字符。

  • □混凝土材料性能按混凝土规范第 4.1 节查表

    • 默认情况下(未勾选),程序计算时所采用的混凝土轴心抗拉强度标准值 ftk、轴心抗压强度设计值 fc、轴心抗拉强度设计值 ft、混凝土的弹性模量 Ec 等材料性能,是根据规范条文说明第 4.1.3~4.1.5 条等提供的公式计算。

    • 当勾选“□混凝土材料性能按混凝土规范第 4.1 节查表”时,与混凝土等级等级值对应的“ftk”“fc”“ft”“Ec”等材料性能按混凝土规范第 4.1 节的表 4.1.3、4.1.4、4.1.5 等各表采用。

    • 请参阅:程序如何确定与混凝土强度等级值相对应的 ftk、fc、ft、Ec 等材料性能?

  • 系统

  • □启动子程序显示动画效果

    • 设置启动子程序时是否显示动画效果。

  • □隐藏不使用的输入界面

    • 默认情况下(未勾选),子程序中当前不使用的输入框、勾选项等控件变灰。

    • 当勾选“□隐藏不使用的输入界面”时,程序中当前不使用的输入框、勾选项等控件将隐藏起来不可见。

  • 属性框行距

    • 设置属性框的行距,有效范围为:17~30。

    • 以【弯矩】子程序为例,下图为“属性框行距”分别取“18”“22”时 子程序不同的界面。

“属性框行距”为 18

“属性框行距”为 22

  • 自动更新

    • 设置自动更新如何工作,可选择“自动下载更新,并安装它们”“有可用更新时通知我”“关闭自动更新”等三种方式。

    • 当“自动更新”为“自动下载更新,并安装它们”时,升级程序将在后台定期检查新版本,如果发现有新版本可供升级,不显示升级界面,且自动完成升级的全部过程。

    • 当“自动更新”为“有可用更新时通知我”时(默认),升级程序将在后台定期检查新版本,如果发现有新版本可供升级,则显示对话询问用户是否立刻升级。

    • 当“自动更新”为“关闭自动更新”时,升级程序不会自动运行,您可以选择下列方法之一手动升级:

      • 从“帮助”下拉菜单中单击“检查更新”,手动启动在线升级向导;

      • 单击“开始”,依次指向“开始”“所有程序”“MorGain 结构快速设计”,然后单击“检查更新版本”,按提示完成升级。

    • 在线更新基于 HTTP 协议。

隐藏/显示程序条

  • 隐藏程序条(H)、显示程序条(H)

    • 点击“隐藏程序条”后,主程序窗口左边的程序条将自动隐藏(类似自动隐藏 Windows 任务栏)。当鼠标箭头移至窗口最左边,程序条将自动弹出。

数据(P)

  • 打开原始数据(I):
      打开扩展名为“.mgs”的文件(MorGain 原始数据文件),程序根据文件内容启动相应的子程序,调入原始输入数据。

  • 保存原始数据(E):
      保存当前正在使用的子程序输入内容,扩展名为“.mgs”。

  • 菜单下方如有文件名,为最近保存的原始数据文件,按下列步骤可设置其最多显示的项目:从“视图”下拉菜单中单击“选项”,选择“原始数据”选项卡,在“保留原始数据的历史记录个数”输入框中选择显示保留个数。